Follow

Service Portal Update Announcement

TLS 1.0 - 1.1 Deprecated. Browser Update Required

To continue to securely access the service portal and helpdesk, please use a modern browser version that supports TLS version 1.2 or above (mandatory after June 14th).

The minimum browser versions include browsers such as Internet Explorer 11, Mozilla Firefox 27, Google Chrome 30 or Apple Safari 7.

If connecting from a mobile device, iOS 5.1 and Android 5 Lollipop or later are required.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.